luaposix: Update source links and urls
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 30 Apr 2014 22:02:05 +0000 (22:02 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 30 Apr 2014 22:02:05 +0000 (22:02 +0000)
No functional change.  The difference in the md5sum of the tarball is
the inclusion of a .gitignore file in the github provided tarball.

This change allows https://home.comcast.net/~sdwalker/uscan/index.html
to more accurately track the state of this package, and includes links
that actually work.  It eliminates the need for this package to be
hosted on mirror2.openwrt.org, and indeed, due to the md5sum change,
won't even be compatible with the package hosted there.

Signed-off-by: Karl Palsson <karlp@remake.is>
SVN-Revision: 40611

lang/luaposix/Makefile

index 726921ebc5291e40c2fc52a23f1a4324ad27a0e3..95e013564ded3e9ee2eea7d6aa0181f02c7e21fc 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luaposix
 PKG_VERSION:=5.1.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/4813
-PKG_MD5SUM:=edb76911dbdabe98dec49e3d8a126227
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE:=v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
+PKG_MD5SUM:=8254576c52bd2d0e160353d24880bb89
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,7 +23,7 @@ define Package/luaposix
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=luaposix
-  URL:=http://luaposix.luaforge.net/
+  URL:=http://luaforge.net/projects/luaposix/
   DEPENDS:=+lua +librt
 endef