this patch fixes a build error described in ticket #6702.
authorTravis Kemen <thepeople@openwrt.org>
Sat, 20 Feb 2010 04:51:10 +0000 (04:51 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Sat, 20 Feb 2010 04:51:10 +0000 (04:51 +0000)
-Raphael

SVN-Revision: 19770

utils/strace/Makefile

index 4caa2e42f325ee389742430165ad3374470c2067..5b096d2fcb189f60c4446bc21b1a3bf049cdc69e 100644 (file)
@@ -40,12 +40,17 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
 system calls a program makes while it is running.
 endef
 
+# needed when compiling against Linux 2.4
 CONFIGURE_VARS += \
        ac_cv_header_linux_netlink_h=yes
 
+# needed when compiling with an external toolchain
 TARGET_CFLAGS += \
        -I$(LINUX_DIR)/include
 
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
+
 define Package/strace/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/