projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d5b734e
)
openssl: host build fails when ccache is enabled
author
John Crispin
<john@openwrt.org>
Mon, 20 Oct 2014 11:19:53 +0000
(11:19 +0000)
committer
John Crispin
<john@openwrt.org>
Mon, 20 Oct 2014 11:19:53 +0000
(11:19 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 43002
package/libs/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/openssl/Makefile
b/package/libs/openssl/Makefile
index 8ffd7f5fedaf81de0e1e6b95dca89381823925ba..b51808bb26cd494519c8a6e22000f1267726a062 100644
(file)
--- a/
package/libs/openssl/Makefile
+++ b/
package/libs/openssl/Makefile
@@
-28,6
+28,11
@@
PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE_CRYPTO CONFIG_OPENSSL_ENGINE_DIGEST \
include $(INCLUDE_DIR)/package.mk
+ifneq ($(CONFIG_CCACHE),)
+HOSTCC=$(HOSTCC_NOCACHE)
+HOSTCXX=$(HOSTCXX_NOCACHE)
+endif
+
define Package/openssl/Default
TITLE:=Open source SSL toolkit
URL:=http://www.openssl.org/