projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
67a31bf
)
fix conflicting optimization flags set by configure
author
Nicolas Thill
<nico@openwrt.org>
Fri, 27 Oct 2006 19:34:09 +0000
(19:34 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Fri, 27 Oct 2006 19:34:09 +0000
(19:34 +0000)
SVN-Revision: 5316
net/ettercap/Makefile
patch
|
blob
|
history
diff --git
a/net/ettercap/Makefile
b/net/ettercap/Makefile
index 920054922090826c423bd7c9f9fcd07269253e97..dbf33101c929a3111b049d9372cf55738f7eec82 100644
(file)
--- a/
net/ettercap/Makefile
+++ b/
net/ettercap/Makefile
@@
-38,6
+38,12
@@
define Package/ettercap/conffiles
/etc/etter.conf
endef
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ # remove default optimization flags set by configure
+ $(SED) 's,DEBUG_FLAGS=.*,DEBUG_FLAGS=,g' $(PKG_BUILD_DIR)/configure
+endef
+
define Build/Configure
$(call Build/Configure/Default, \
--with-libpcap="$(STAGING_DIR)/usr" \
@@
-53,7
+59,6
@@
define Build/Configure
)
endef
-
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \