Update error message on old unsupported kernels
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 11 Jan 2010 18:11:25 +0000 (10:11 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 11 Jan 2010 18:11:25 +0000 (10:11 -0800)
compat-wireless-2.6-old is deprecated as we can now use
compat-wireless itself but we just need to work extending
support for older kernels. It will also soon be possible
for users to enable older kernels by just selecting
one driver to compile.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index 3972e7a65af2aa2cccc005c26cfdf3606e5bcdd1..3a13e8a2b497604a3494f350131a2dc21e15cc8c 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -52,7 +52,7 @@ COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNE
 $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
 
 ifdef CONFIG_COMPAT_KERNEL_25
-$(error "ERROR: You should use compat-wireless-2.6-old for older kernels, this one is for kernels >= 2.6.25")
+$(error "ERROR: compat-wireless by default supports kernels >= 2.6.25, try enabling only one driver though"
 endif
 
 ifeq ($(CONFIG_CFG80211),y)