tools: util-linux: mark hexdump patch as backport
authorRobert Marko <robimarko@gmail.com>
Thu, 27 Jun 2024 10:22:01 +0000 (12:22 +0200)
committerRobert Marko <robimarko@gmail.com>
Thu, 27 Jun 2024 10:22:53 +0000 (12:22 +0200)
The hexdump fix for --disable-all-programs has been merged upstream, so
mark it so.

Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/util-linux/patches/0001-hexdump-allow-enabling-with-disable-all-programs.patch [new file with mode: 0644]
tools/util-linux/patches/100-hexdump-allow-enabling-with-disable-all-programs.patch [deleted file]

diff --git a/tools/util-linux/patches/0001-hexdump-allow-enabling-with-disable-all-programs.patch b/tools/util-linux/patches/0001-hexdump-allow-enabling-with-disable-all-programs.patch
new file mode 100644 (file)
index 0000000..c0c1f04
--- /dev/null
@@ -0,0 +1,28 @@
+From 37641f246ee9df7289b4e3054b3ded3912773722 Mon Sep 17 00:00:00 2001
+From: Robert Marko <robimarko@gmail.com>
+Date: Tue, 25 Jun 2024 17:32:08 +0200
+Subject: [PATCH] hexdump: allow enabling with --disable-all-programs
+
+Currently, if --disable-all-programs is used hexdump cannot be built
+as --enable-hexdump is not recognized, so lets add support for it.
+
+Signed-off-by: Robert Marko <robimarko@gmail.com>
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2237,7 +2237,11 @@ UL_BUILD_INIT([column], [check])
+ UL_REQUIRES_BUILD([column], [libsmartcols])
+ AM_CONDITIONAL([BUILD_COLUMN], [test "x$build_column" = xyes])
+-UL_BUILD_INIT([hexdump], [yes])
++AC_ARG_ENABLE([hexdump],
++  AS_HELP_STRING([--disable-hexdump], [do not build hexdump]),
++  [], [UL_DEFAULT_ENABLE([hexdump], [check])]
++)
++UL_BUILD_INIT([hexdump])
+ AM_CONDITIONAL([BUILD_HEXDUMP], [test "x$build_hexdump" = xyes])
+ UL_BUILD_INIT([rev], [yes])
diff --git a/tools/util-linux/patches/100-hexdump-allow-enabling-with-disable-all-programs.patch b/tools/util-linux/patches/100-hexdump-allow-enabling-with-disable-all-programs.patch
deleted file mode 100644 (file)
index c0c1f04..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From 37641f246ee9df7289b4e3054b3ded3912773722 Mon Sep 17 00:00:00 2001
-From: Robert Marko <robimarko@gmail.com>
-Date: Tue, 25 Jun 2024 17:32:08 +0200
-Subject: [PATCH] hexdump: allow enabling with --disable-all-programs
-
-Currently, if --disable-all-programs is used hexdump cannot be built
-as --enable-hexdump is not recognized, so lets add support for it.
-
-Signed-off-by: Robert Marko <robimarko@gmail.com>
----
- configure.ac | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -2237,7 +2237,11 @@ UL_BUILD_INIT([column], [check])
- UL_REQUIRES_BUILD([column], [libsmartcols])
- AM_CONDITIONAL([BUILD_COLUMN], [test "x$build_column" = xyes])
--UL_BUILD_INIT([hexdump], [yes])
-+AC_ARG_ENABLE([hexdump],
-+  AS_HELP_STRING([--disable-hexdump], [do not build hexdump]),
-+  [], [UL_DEFAULT_ENABLE([hexdump], [check])]
-+)
-+UL_BUILD_INIT([hexdump])
- AM_CONDITIONAL([BUILD_HEXDUMP], [test "x$build_hexdump" = xyes])
- UL_BUILD_INIT([rev], [yes])