ramips: fix lzma-loader for ASIARF boards
authorDaniel Danzberger <daniel@dd-wrt.com>
Fri, 2 Jun 2023 17:36:28 +0000 (19:36 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 7 Jun 2023 07:07:06 +0000 (09:07 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of similar devices.

Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
(cherry picked from commit 29a5cb7a8b105ca6534bba63edcec48ae935c078)

target/linux/ramips/image/mt7621.mk

index 2697f84bf7684d5ad2b724b4bd93c4e1504112dd..6f50623acbba933d726defde9f29a011b8a9b113 100644 (file)
@@ -237,6 +237,7 @@ TARGET_DEVICES += arcadyan_we420223-99
 
 define Device/asiarf_ap7621-001
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16000k
   DEVICE_VENDOR := AsiaRF
   DEVICE_MODEL := AP7621-001
@@ -247,6 +248,7 @@ TARGET_DEVICES += asiarf_ap7621-001
 
 define Device/asiarf_ap7621-nv1
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16000k
   DEVICE_VENDOR := AsiaRF
   DEVICE_MODEL := AP7621-NV1