linux-firmware: disable stripping
authorRobert Marko <robimarko@gmail.com>
Wed, 28 Dec 2022 21:57:49 +0000 (22:57 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 27 May 2023 20:05:14 +0000 (22:05 +0200)
It has been brought to my attention that recently added WCN6855 firmware
is broken as it is getting stripped during building due to being 2 ELF
binaries.
I am sure WCN6750 and any other ELF binaries are having the same issue,
so since stripping firmware binaries is clearly unwanted disable it.

Fixes: b4d3694f81f4 ("linux-firmware: package ath11k consumer cards firmware")
Signed-off-by: Robert Marko <robimarko@gmail.com>
(cherry picked from commit 9d8eff6799469e2ed8a5d2e4decd194902c1ec1b)

package/firmware/linux-firmware/Makefile

index 29c48086dd57a41bb4dd3cdfbf9ff402f6e326c8..c6c605ba68f0066a25fc0be55c317fcd0b4aefde 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linux-firmware
 PKG_VERSION:=20221214
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -21,6 +21,9 @@ SCAN_DEPS = *.mk
 
 include $(INCLUDE_DIR)/package.mk
 
+RSTRIP:=:
+STRIP:=:
+
 define Package/firmware-default
   SECTION:=firmware
   CATEGORY:=Firmware