Add bluetooth support to whiterussian, closes #599
authorFlorian Fainelli <florian@openwrt.org>
Mon, 24 Jul 2006 09:45:27 +0000 (09:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 24 Jul 2006 09:45:27 +0000 (09:45 +0000)
SVN-Revision: 4255

12 files changed:
openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-bluetooth-bfusb.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-bluecard.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-bt3c.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-btuart.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-dtl1.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-hciuart.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-hciusb.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth-hcivhci.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-bluetooth.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index d65db55057553fec91a0e0c2167a13828a2e2ad5..3fda2c03ff5101ac26c7b04183e284ccacf22f34 100644 (file)
@@ -426,5 +426,72 @@ config BR2_PACKAGE_KMOD_BONDING
        help
          Kernel modules for ethernet bonding
 
+config BR2_PACKAGE_KMOD_BLUETOOTH
+       tristate "Kernel driver for Bluetooth stack"
+       default m
+       help
+         Kernel modules for Bluetooth stack
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_BFUSB
+       tristate "Bluetooth HCI BlueFRITZ! USB driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       select BR2_PACKAGE_KMOD_USB
+       default m
+       help
+         Bluetooth HCI BlueFRITZ! USB driver
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_BLUECARD
+       tristate "Bluetooth HCI BlueCard (PC Card) driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       select BR2_PACKAGE_KMOD_PCMCIA
+       default m
+       help
+         Bluetooth HCI BlueCard (PC Card) driver
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_BT3C
+       tristate "Bluetooth HCI BT3C (PC Card) driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       select BR2_PACKAGE_KMOD_PCMCIA
+       default m
+       help
+         Bluetooth HCI BT3C (PC Card) driver
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_BTUART
+       tristate "Bluetooth HCI UART (PC Card) driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       select BR2_PACKAGE_KMOD_PCMCIA
+       default m
+       help
+         Bluetooth HCI UART (PC Card) driver
+       
+config BR2_PACKAGE_KMOD_BLUETOOTH_DTL1
+       tristate "Bluetooth HCI DTL1 (PC Card) driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       select BR2_PACKAGE_KMOD_PCMCIA
+       default m
+       help
+         Bluetooth HCI DTL1 (PC Card) driver
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_HCIUART
+       tristate "Bluetooth HCI UART driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       default m
+       help
+         Bluetooth HCI UART driver
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_HCIUSB
+       tristate "Bluetooth HCI USB driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       depends BR2_PACKAGE_KMOD_USB
+       default m
+       help
+         Bluetooth HCI USB driver
+
+config BR2_PACKAGE_KMOD_BLUETOOTH_HCIVHCI
+       tristate "Bluetooth Virtual HCI device driver"
+       depends BR2_PACKAGE_KMOD_BLUETOOTH
+       default m
+       help
+         Bluetooth Virtual HCI device driver
 
 source "target/linux/package/Config.in"
diff --git a/openwrt/target/linux/control/kmod-bluetooth-bfusb.control b/openwrt/target/linux/control/kmod-bluetooth-bfusb.control
new file mode 100644 (file)
index 0000000..577605c
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-bfusb
+Priority: optional
+Section: net
+Depends: kmod-bluetooth kmod-usb-core
+Description: Bluetooth HCI BlueFRITZ! USB driver
diff --git a/openwrt/target/linux/control/kmod-bluetooth-bluecard.control b/openwrt/target/linux/control/kmod-bluetooth-bluecard.control
new file mode 100644 (file)
index 0000000..ec4feb5
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-bluecard
+Priority: optional
+Section: net
+Depends: kmod-bluetooth kmod-pcmcia
+Description: Bluetooth HCI BlueCard (PC Card) driver
diff --git a/openwrt/target/linux/control/kmod-bluetooth-bt3c.control b/openwrt/target/linux/control/kmod-bluetooth-bt3c.control
new file mode 100644 (file)
index 0000000..a773b54
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-bt3c
+Priority: optional
+Section: net
+Depends: kmod-bluetooth kmod-pcmcia
+Description: Bluetooth HCI BT3C (PC Card) drive
diff --git a/openwrt/target/linux/control/kmod-bluetooth-btuart.control b/openwrt/target/linux/control/kmod-bluetooth-btuart.control
new file mode 100644 (file)
index 0000000..f091110
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-btuart
+Priority: optional
+Section: net
+Depends: kmod-bluetooth kmod-pcmcia
+Description: Bluetooth HCI UART (PC Card) driver.
diff --git a/openwrt/target/linux/control/kmod-bluetooth-dtl1.control b/openwrt/target/linux/control/kmod-bluetooth-dtl1.control
new file mode 100644 (file)
index 0000000..0e28c66
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-dtl1
+Priority: optional
+Section: net
+Depends: kmod-bluetooth kmod-pcmcia
+Description: Bluetooth HCI DTL1 (PC Card) driver
diff --git a/openwrt/target/linux/control/kmod-bluetooth-hciuart.control b/openwrt/target/linux/control/kmod-bluetooth-hciuart.control
new file mode 100644 (file)
index 0000000..ddb9bad
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-hciuart
+Priority: optional
+Section: net
+Depends: kmod-bluetooth
+Description: Bluetooth HCI UART driver
diff --git a/openwrt/target/linux/control/kmod-bluetooth-hciusb.control b/openwrt/target/linux/control/kmod-bluetooth-hciusb.control
new file mode 100644 (file)
index 0000000..63d2b78
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-hciusb
+Priority: optional
+Section: net
+Depends: kmod-bluetooth kmod-usb-core
+Description: Bluetooth HCI USB driver
diff --git a/openwrt/target/linux/control/kmod-bluetooth-hcivhci.control b/openwrt/target/linux/control/kmod-bluetooth-hcivhci.control
new file mode 100644 (file)
index 0000000..5e948a2
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-bluetooth-hcivhci
+Priority: optional
+Section: net
+Depends: kmod-bluetooth
+Description: Bluetooth Virtual HCI device driver
diff --git a/openwrt/target/linux/control/kmod-bluetooth.control b/openwrt/target/linux/control/kmod-bluetooth.control
new file mode 100644 (file)
index 0000000..47dfec9
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-bluetooth
+Priority: optional
+Section: net
+Description: Bluetooth stack kernel modules
index a8deae670755fd4e0df5a61033c540cc337efbcc..1ce1b574c9d9f13e2708076f3499feffccab409b 100644 (file)
@@ -243,6 +243,46 @@ $(eval $(call KMOD_template,BONDING,bonding,\
        $(MODULES_DIR)/kernel/drivers/net/bonding/bonding.o \
 ))
 
+$(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
+       $(MODULES_DIR)/kernel/net/bluetooth/bluez.o \
+       $(MODULES_DIR)/kernel/net/bluetooth/bnep/bnep.o \
+       $(MODULES_DIR)/kernel/net/bluetooth/l2cap.o \
+       $(MODULES_DIR)/kernel/net/bluetooth/rfcomm/rfcomm.o \
+       $(MODULES_DIR)/kernel/net/bluetooth/sco.o \
+,CONFIG_BLUEZ,,30,bluez bnep l2cap rfcomm sco))
+
+$(eval $(call KMOD_template,BLUETOOTH_BFUSB,bluetooth-bfusb,\
+       $(MODULES_DIR)/kernel/drivers/bluetooth/bfusb.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_BLUECARD,bluetooth-bluecard,\
+       $(MODULES_DIR)/kernel/drivers/bluetooth/bluecard_cs.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_BT3C,bluetooth-bt3c,\
+        $(MODULES_DIR)/kernel/drivers/bluetooth/bt3c_cs.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_BTUART,bluetooth-btuart,\
+        $(MODULES_DIR)/kernel/drivers/bluetooth/btuart_cs.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_DTL1,bluetooth-dtl1,\
+        $(MODULES_DIR)/kernel/drivers/bluetooth/dtl1_cs.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_HCIUART,bluetooth-hciuart,\
+        $(MODULES_DIR)/kernel/drivers/bluetooth/hci_uart.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_HCIUSB,bluetooth-hciusb,\
+        $(MODULES_DIR)/kernel/drivers/bluetooth/hci_usb.o \
+))
+
+$(eval $(call KMOD_template,BLUETOOTH_HCIVHCI,bluetooth-hcivhci,\
+        $(MODULES_DIR)/kernel/drivers/bluetooth/hci_vhci.o \
+))
+
 $(TARGETS): $(PACKAGE_DIR)
 
 $(PACKAGE_DIR):
index 9904d6ebd0fff3d8e50417dc5919ad5c4dc73008..20a95fcb03ebd0f799827e26c7e7bb54d455519b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Automatically generated by make menuconfig: don't edit
+# Automatically generated make config: don't edit
 #
 CONFIG_MIPS=y
 CONFIG_MIPS32=y
@@ -186,6 +186,10 @@ CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_CONCAT is not set
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_CMDLINE_PARTS is not set
+
+#
+# User Modules And Translation Layers
+#
 CONFIG_MTD_CHAR=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_FTL is not set
@@ -250,6 +254,10 @@ CONFIG_MTD_BCM947XX=y
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_MTDRAM is not set
 # CONFIG_MTD_BLKMTD is not set
+
+#
+# Disk-On-Chip Device Drivers
+#
 # CONFIG_MTD_DOC1000 is not set
 # CONFIG_MTD_DOC2000 is not set
 # CONFIG_MTD_DOC2001 is not set
@@ -387,10 +395,10 @@ CONFIG_IP_NF_NAT_NEEDED=y
 CONFIG_IP_NF_TARGET_MASQUERADE=y
 CONFIG_IP_NF_TARGET_REDIRECT=m
 CONFIG_IP_NF_NAT_PPTP=m
-CONFIG_IP_NF_NAT_H323=m
-CONFIG_IP_NF_NAT_RTSP=m
 CONFIG_IP_NF_NAT_PROTO_GRE=m
 CONFIG_IP_NF_NAT_AMANDA=m
+CONFIG_IP_NF_NAT_H323=m
+CONFIG_IP_NF_NAT_RTSP=m
 CONFIG_IP_NF_NAT_SNMP_BASIC=m
 CONFIG_IP_NF_NAT_IRC=y
 CONFIG_IP_NF_NAT_FTP=y
@@ -447,6 +455,10 @@ CONFIG_IP6_NF_TARGET_IMQ=m
 # CONFIG_IP_SCTP is not set
 # CONFIG_ATM is not set
 CONFIG_VLAN_8021Q=y
+
+#
+#  
+#
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
 # CONFIG_DECNET is not set
@@ -531,6 +543,10 @@ CONFIG_IDE=m
 # IDE, ATA and ATAPI Block devices
 #
 CONFIG_BLK_DEV_IDE=m
+
+#
+# Please see Documentation/ide.txt for help/info on IDE drives
+#
 # CONFIG_BLK_DEV_HD_IDE is not set
 # CONFIG_BLK_DEV_HD is not set
 # CONFIG_BLK_DEV_IDE_SATA is not set
@@ -544,6 +560,10 @@ CONFIG_IDEDISK_STROKE=y
 # CONFIG_BLK_DEV_IDEFLOPPY is not set
 # CONFIG_BLK_DEV_IDESCSI is not set
 # CONFIG_IDE_TASK_IOCTL is not set
+
+#
+# IDE chipset support/bugfixes
+#
 # CONFIG_BLK_DEV_CMD640 is not set
 # CONFIG_BLK_DEV_CMD640_ENHANCED is not set
 # CONFIG_BLK_DEV_ISAPNP is not set
@@ -601,12 +621,20 @@ CONFIG_BLK_DEV_PDC202XX=y
 # SCSI support
 #
 CONFIG_SCSI=m
+
+#
+# SCSI support type (disk, tape, CD-ROM)
+#
 CONFIG_BLK_DEV_SD=m
 CONFIG_SD_EXTRA_DEVS=5
 # CONFIG_CHR_DEV_ST is not set
 # CONFIG_CHR_DEV_OSST is not set
 # CONFIG_BLK_DEV_SR is not set
 CONFIG_CHR_DEV_SG=m
+
+#
+# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
+#
 # CONFIG_SCSI_DEBUG_QUEUES is not set
 CONFIG_SCSI_MULTI_LUN=y
 # CONFIG_SCSI_CONSTANTS is not set
@@ -747,7 +775,6 @@ CONFIG_NET_PCI=y
 # CONFIG_ADAPTEC_STARFIRE is not set
 # CONFIG_APRICOT is not set
 CONFIG_B44=y
-CONFIG_ET=m
 # CONFIG_CS89x0 is not set
 # CONFIG_TULIP is not set
 # CONFIG_DE4X5 is not set
@@ -910,6 +937,14 @@ CONFIG_PPDEV=m
 # Joysticks
 #
 # CONFIG_INPUT_GAMEPORT is not set
+
+#
+# Input core support is needed for gameports
+#
+
+#
+# Input core support is needed for joysticks
+#
 # CONFIG_QIC02_TAPE is not set
 # CONFIG_IPMI_HANDLER is not set
 # CONFIG_IPMI_PANIC_EVENT is not set
@@ -1140,6 +1175,10 @@ CONFIG_VIDEO_DEV=m
 #
 CONFIG_VIDEO_PROC_FS=y
 # CONFIG_I2C_PARPORT is not set
+
+#
+# Video Adapters
+#
 # CONFIG_VIDEO_BT848 is not set
 # CONFIG_VIDEO_PMS is not set
 # CONFIG_VIDEO_BWQCAM is not set
@@ -1173,15 +1212,30 @@ CONFIG_VIDEO_PROC_FS=y
 #
 CONFIG_USB=m
 # CONFIG_USB_DEBUG is not set
+
+#
+# Miscellaneous USB options
+#
 CONFIG_USB_DEVICEFS=y
 # CONFIG_USB_BANDWIDTH is not set
+
+#
+# USB Host Controller Drivers
+#
 CONFIG_USB_EHCI_HCD=m
 # CONFIG_USB_UHCI is not set
 CONFIG_USB_UHCI_ALT=m
 CONFIG_USB_OHCI=m
+
+#
+# USB Device Class drivers
+#
 # CONFIG_USB_AUDIO is not set
 # CONFIG_USB_EMI26 is not set
-# CONFIG_USB_BLUETOOTH is not set
+
+#
+#   USB Bluetooth can only be used with disabled Bluetooth subsystem
+#
 # CONFIG_USB_MIDI is not set
 CONFIG_USB_STORAGE=m
 # CONFIG_USB_STORAGE_DEBUG is not set
@@ -1195,7 +1249,15 @@ CONFIG_USB_STORAGE_SDDR55=y
 CONFIG_USB_STORAGE_JUMPSHOT=y
 CONFIG_USB_ACM=m
 CONFIG_USB_PRINTER=m
+
+#
+# USB Human Interface Devices (HID)
+#
 # CONFIG_USB_HID is not set
+
+#
+#     Input core support is needed for USB HID input layer or HIDBP support
+#
 # CONFIG_USB_HIDINPUT is not set
 # CONFIG_USB_HIDDEV is not set
 # CONFIG_USB_KBD is not set
@@ -1204,11 +1266,19 @@ CONFIG_USB_PRINTER=m
 # CONFIG_USB_WACOM is not set
 # CONFIG_USB_KBTAB is not set
 # CONFIG_USB_POWERMATE is not set
+
+#
+# USB Imaging devices
+#
 # CONFIG_USB_DC2XX is not set
 # CONFIG_USB_MDC800 is not set
 # CONFIG_USB_SCANNER is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_HPUSBSCSI is not set
+
+#
+# USB Multimedia devices
+#
 # CONFIG_USB_IBMCAM is not set
 # CONFIG_USB_KONICAWC is not set
 # CONFIG_USB_OV511 is not set
@@ -1219,12 +1289,20 @@ CONFIG_USB_PWC=m
 # CONFIG_USB_VICAM is not set
 # CONFIG_USB_DSBR is not set
 # CONFIG_USB_DABUSB is not set
+
+#
+# USB Network adaptors
+#
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
 # CONFIG_USB_KAWETH is not set
 # CONFIG_USB_CATC is not set
 # CONFIG_USB_CDCETHER is not set
 # CONFIG_USB_USBNET is not set
+
+#
+# USB port drivers
+#
 # CONFIG_USB_USS720 is not set
 
 #
@@ -1252,11 +1330,10 @@ CONFIG_USB_SERIAL_PL2303=m
 # CONFIG_USB_SERIAL_CYBERJACK is not set
 # CONFIG_USB_SERIAL_XIRCOM is not set
 # CONFIG_USB_SERIAL_OMNINET is not set
-# CONFIG_USB_RIO500 is not set
-# CONFIG_USB_AUERSWALD is not set
-# CONFIG_USB_TIGL is not set
-# CONFIG_USB_BRLVGER is not set
-# CONFIG_USB_LCD is not set
+
+#
+# USB Miscellaneous drivers
+#
 # CONFIG_USB_RIO500 is not set
 # CONFIG_USB_AUERSWALD is not set
 # CONFIG_USB_TIGL is not set
@@ -1271,7 +1348,30 @@ CONFIG_USB_SERIAL_PL2303=m
 #
 # Bluetooth support
 #
-# CONFIG_BLUEZ is not set
+CONFIG_BLUEZ=m
+CONFIG_BLUEZ_L2CAP=m
+CONFIG_BLUEZ_SCO=m
+CONFIG_BLUEZ_RFCOMM=m
+CONFIG_BLUEZ_RFCOMM_TTY=y
+CONFIG_BLUEZ_BNEP=m
+CONFIG_BLUEZ_BNEP_MC_FILTER=y
+CONFIG_BLUEZ_BNEP_PROTO_FILTER=y
+
+#
+# Bluetooth device drivers
+#
+CONFIG_BLUEZ_HCIUSB=m
+CONFIG_BLUEZ_HCIUSB_SCO=y
+CONFIG_BLUEZ_HCIUART=m
+CONFIG_BLUEZ_HCIUART_H4=y
+CONFIG_BLUEZ_HCIUART_BCSP=y
+CONFIG_BLUEZ_HCIUART_BCSP_TXCRC=y
+CONFIG_BLUEZ_HCIBFUSB=m
+CONFIG_BLUEZ_HCIDTL1=m
+CONFIG_BLUEZ_HCIBT3C=m
+CONFIG_BLUEZ_HCIBLUECARD=m
+CONFIG_BLUEZ_HCIBTUART=m
+CONFIG_BLUEZ_HCIVHCI=m
 
 #
 # Kernel hacking