projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
468a4b5
)
iptables: fix dependency for libip6tc on IPV6
author
Rosy Song
<rosysong@rosinson.com>
Thu, 9 Aug 2018 06:47:31 +0000
(14:47 +0800)
committer
Jo-Philipp Wich
<jo@mein.io>
Tue, 18 Dec 2018 10:28:14 +0000
(11:28 +0100)
Signed-off-by: Rosy Song <rosysong@rosinson.com>
(backported from
2dc1f54b1205094e7c6036cae6275d2c326bad3e
)
package/network/utils/iptables/Makefile
patch
|
blob
|
history
diff --git
a/package/network/utils/iptables/Makefile
b/package/network/utils/iptables/Makefile
index 9c7179c51dc950b82df83b45f8fab184b93a48d1..c1e4790d11a1a138a0ed819685096f9e1f137fc9 100644
(file)
--- a/
package/network/utils/iptables/Makefile
+++ b/
package/network/utils/iptables/Makefile
@@
-462,7
+462,7
@@
define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libip4tc +libip6tc +libxtables
+ DEPENDS:=+libip4tc +
IPV6:
libip6tc +libxtables
ABI_VERSION:=$(PKG_VERSION)
TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
endef
@@
-482,7
+482,7
@@
$(call Package/iptables/Default)
CATEGORY:=Libraries
TITLE:=IPv6 firewall - shared libiptc library
ABI_VERSION:=$(PKG_VERSION)
- DEPENDS:=+libxtables
+ DEPENDS:=
@IPV6
+libxtables
endef
define Package/libxtables