projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9ecec14
)
fix KERNEL_PATCHVER, properly strip -rc* suffixes
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 23 Apr 2009 14:55:07 +0000
(14:55 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 23 Apr 2009 14:55:07 +0000
(14:55 +0000)
SVN-Revision: 15353
include/kernel-version.mk
patch
|
blob
|
history
diff --git
a/include/kernel-version.mk
b/include/kernel-version.mk
index 1463958f6750944633f782be2049f85083c4d869..07c318d942ddc0625e2970b2f8a3cdea11c2f414 100644
(file)
--- a/
include/kernel-version.mk
+++ b/
include/kernel-version.mk
@@
-45,5
+45,5
@@
split_version=$(subst ., ,$(1))
merge_version=$(subst $(space),.,$(1))
KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
-KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(
LINUX_VERSION
))))
+KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(
KERNEL_BASE
))))