fix #628 and #646 in whiterussian as well
authorImre Kaloz <kaloz@openwrt.org>
Fri, 21 Jul 2006 10:56:56 +0000 (10:56 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 21 Jul 2006 10:56:56 +0000 (10:56 +0000)
SVN-Revision: 4186

openwrt/toolchain/ipkg-utils/1.7/ipkg-utils-1.7-ipkg_tar_wildcards.patch [new file with mode: 0644]
openwrt/toolchain/kernel-headers/Makefile

diff --git a/openwrt/toolchain/ipkg-utils/1.7/ipkg-utils-1.7-ipkg_tar_wildcards.patch b/openwrt/toolchain/ipkg-utils/1.7/ipkg-utils-1.7-ipkg_tar_wildcards.patch
new file mode 100644 (file)
index 0000000..80a7d1d
--- /dev/null
@@ -0,0 +1,23 @@
+--- ipkg-utils-1.7/ipkg.py.orig        2006-06-29 14:16:00.000000000 +0200
++++ ipkg-utils-1.7/ipkg.py     2006-06-29 14:36:01.000000000 +0200
+@@ -93,9 +93,9 @@
+             self.filename = os.path.basename(fn)
+           ## sys.stderr.write("  extracting control.tar.gz from %s\n"% (fn,)) 
+             if self.isdeb:
+-                control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - '*control'","r")
++                control = os.popen("ar p "+fn+" control.tar.gz | tar xzO --wildcards -f - '*control'","r")
+             else:
+-                control = os.popen("tar xfzO "+fn+" '*control.tar.gz' | tar xfzO - '*control'","r")
++                control = os.popen("tar xzO --wildcards -f "+fn+" '*control.tar.gz' | tar xzO --wildcards -f - '*control'","r")
+             line = control.readline()
+             while 1:
+                 if not line: break
+@@ -122,7 +122,7 @@
+             if self.isdeb:
+                 data = os.popen("ar p "+fn+" data.tar.gz | tar tfz -","r")
+             else:
+-                data = os.popen("tar xfzO "+fn+" '*data.tar.gz' | tar tfz -","r")
++                data = os.popen("tar xzO --wildcards -f "+fn+" '*data.tar.gz' | tar tfz -","r")
+             while 1:
+                 line = data.readline()
+                 if not line: break
index 5187fbd5fbd1107c682b795f655345b2aa01444c..d7b9746abaa03488bfb20e9325adf28fc9affad7 100644 (file)
@@ -22,7 +22,7 @@ $(DL_DIR)/$(LINUX_HEADERS_SOURCE):
 
 $(LINUX_HEADERS_DIR)/.unpacked: $(DL_DIR)/$(LINUX_HEADERS_SOURCE)
        mkdir -p $(TOOL_BUILD_DIR)
-       bzcat $(DL_DIR)/$(LINUX_HEADERS_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) - \
+       bzcat $(DL_DIR)/$(LINUX_HEADERS_SOURCE) | tar --wildcards -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) - \
                linux-$(LINUX_HEADERS_VERSION)/include \
                linux-$(LINUX_HEADERS_VERSION)/Makefile \
                linux-$(LINUX_HEADERS_VERSION)/Rules.make \