projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fc60b97
)
readline: add host PIC
author
Rosen Penev
<rosenp@gmail.com>
Thu, 31 Mar 2022 04:33:01 +0000
(21:33 -0700)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 16 Apr 2022 12:02:11 +0000
(14:02 +0200)
Python seems to fail to link to libreadline properly because of this.
Not a fatal error but an error nontheless.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/readline/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/readline/Makefile
b/package/libs/readline/Makefile
index d14f058eabae02f1cc02603618f076bf27a851f1..9cf061a648c66ce417eb9f64df4d0b9c7d8d335c 100644
(file)
--- a/
package/libs/readline/Makefile
+++ b/
package/libs/readline/Makefile
@@
-53,6
+53,7
@@
CONFIGURE_VARS += \
bash_cv_func_sigsetjmp=yes \
TARGET_CFLAGS += $(FPIC)
+HOST_CFLAGS += $(FPIC)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include