ath79: remove 5GHz wifi bits from Sophos AP15
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>
Sun, 11 Aug 2024 19:53:24 +0000 (21:53 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 24 Aug 2024 12:38:57 +0000 (14:38 +0200)
Sophos AP15 only uses the SoC's built-in wifi. There's no external PCIe
chipset.

Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Link: https://github.com/openwrt/openwrt/pull/16187
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ath79/dts/qca9558_sophos_ap15.dts
target/linux/ath79/image/generic.mk

index 7949d3e88f4501dbb2617dc0cdae7f67a5c1a48e..de54948c8789958cd05998bca11043f5f27ab5a5 100644 (file)
        };
 };
 
-&pcie0 {
-       status = "okay";
-
-       wifi@0,0 {
-               compatible = "qcom,ath10k";
-               reg = <0x0000 0 0 0 0>;
-               nvmem-cells = <&cal_art_5000>;
-               nvmem-cell-names = "calibration";
-       };
-};
-
 &spi {
        status = "okay";
 
                                        cal_art_1000: calibration@1000 {
                                                reg = <0x1000 0x440>;
                                        };
-
-                                       cal_art_5000: calibration@5000 {
-                                               reg = <0x5000 0x844>;
-                                       };
                                };
                        };
 
index 00aa6881567513c1e5fb30abf5f52516188f7425..8bfa3599108cf4189063a848520097ea3c83fdcc 100644 (file)
@@ -2916,7 +2916,6 @@ define Device/sophos_ap15
   SOC := qca9558
   DEVICE_VENDOR := Sophos
   DEVICE_MODEL := AP15
-  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 15936k
 endef
 TARGET_DEVICES += sophos_ap15