include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipsec-tools
-PKG_VERSION:=0.8.0
-PKG_RELEASE:=2
+PKG_VERSION:=0.8.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/ipsec-tools
-PKG_MD5SUM:=b79aae3055a51f8de5c0f1b8ca6cf619
+PKG_MD5SUM:=d38b39f291ba2962387c3232e7335dd8
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
--- a/src/racoon/oakley.c
+++ b/src/racoon/oakley.c
-@@ -2419,8 +2419,21 @@ oakley_skeyid(iph1)
+@@ -2424,8 +2424,21 @@ oakley_skeyid(iph1)
plog(LLV_ERROR, LOCATION, iph1->remote,
"couldn't find the pskey for %s.\n",
saddrwop2str(iph1->remote));
--- a/configure.ac
+++ b/configure.ac
-@@ -75,9 +75,10 @@ case "$host_os" in
+@@ -74,9 +74,10 @@ case "$host_os" in
[ KERNEL_INCLUDE="/lib/modules/`uname -r`/build/include" ])
AC_CHECK_HEADER($KERNEL_INCLUDE/linux/pfkeyv2.h, ,
AC_SUBST(KERNEL_INCLUDE)
# We need the configure script to run with correct kernel headers.
# However we don't want to point to kernel source tree in compile time,
-@@ -644,7 +645,14 @@ AC_EGREP_CPP(yes,
+@@ -643,7 +644,14 @@ AC_EGREP_CPP(yes,
#ifdef SADB_X_EXT_NAT_T_TYPE
yes
#endif
@@ -1,14 +1,7 @@
-
-.includes: ${top_builddir}/config.status
-- ln -sf $(KERNEL_INCLUDE)/linux
+- ln -snf $(KERNEL_INCLUDE)/linux
- touch .includes
-
-all: .includes