compat-wireless: fix old kernel checks for 3.x
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Sat, 25 Feb 2012 04:42:39 +0000 (20:42 -0800)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Sat, 25 Feb 2012 04:42:39 +0000 (20:42 -0800)
These ancient checks require a check against the 2 release
as the KERNEL_26SUBLEVEL is only defined when that kernel
is detected.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
config.mk

index 4bbbd88193db3825a3d9c5442c8c92c0611f3905..668f9fbb7ab066fc1def719f0d5b07ae7f8978db 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -36,11 +36,13 @@ endif
 # you have it enabled, otherwise you will very likely run into
 # a kernel panic.
 # XXX: move this to compat_autoconf.h script generation
+ifeq ($(KERNEL_VERSION),2)
 ifeq ($(shell test $(KERNEL_VERSION) -eq 2 -a $(KERNEL_26SUBLEVEL) -eq 27 && echo yes),yes)
 ifeq ($(CONFIG_DYNAMIC_FTRACE),y)
 $(error "ERROR: Your 2.6.27 kernel has CONFIG_DYNAMIC_FTRACE, please upgrade your distribution kernel as newer ones should not have this enabled (and if so report a bug) or remove this warning if you know what you are doing")
 endif
 endif
+endif
 
 # This is because with CONFIG_MAC80211 include/linux/skbuff.h will
 # enable on 2.6.27 a new attribute:
@@ -54,11 +56,13 @@ endif
 # In kernel 2.6.32 both attributes were removed.
 #
 # XXX: move this to compat_autoconf.h script generation
+ifeq ($(KERNEL_VERSION),2)
 ifeq ($(shell test $(KERNEL_VERSION) -eq 2 -a $(KERNEL_26SUBLEVEL) -ge 27 -a $(KERNEL_26SUBLEVEL) -le 31 && echo yes),yes)
 ifeq ($(CONFIG_MAC80211),)
 $(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
 endif
 endif
+endif
 
 ifneq ($(KERNELRELEASE),) # This prevents a warning