projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
252c222
)
make the compile: host-install dependency independent of the order in which the makef...
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 12 Mar 2009 14:07:08 +0000
(14:07 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 12 Mar 2009 14:07:08 +0000
(14:07 +0000)
SVN-Revision: 14853
include/host-build.mk
patch
|
blob
|
history
diff --git
a/include/host-build.mk
b/include/host-build.mk
index e92c7b3e68f33ec435d63a5357a2b5044ab83b88..a0ffd83b6e0bec3145a80f4b22741bfeb8b7bf42 100644
(file)
--- a/
include/host-build.mk
+++ b/
include/host-build.mk
@@
-122,7
+122,7
@@
ifndef DUMP
host-install: $(HOST_STAMP_INSTALLED)
endif
- download:
+ $(if $(STAMP_BUILT),compile: host-install)
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)
host-compile: $(HOST_STAMP_BUILT)
@@
-134,8
+134,9
@@
ifndef DUMP
endef
+ download:
prepare: host-prepare
- compile: host-compile
$(if $(STAMP_BUILT),host-install)
+ compile: host-compile
install: host-install
clean: host-clean