projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d84ecd2
)
libffi: split build and source directory to work around some makefile bugs
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 6 Jul 2012 09:23:05 +0000
(09:23 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 6 Jul 2012 09:23:05 +0000
(09:23 +0000)
SVN-Revision: 32632
libs/libffi/Makefile
patch
|
blob
|
history
diff --git
a/libs/libffi/Makefile
b/libs/libffi/Makefile
index 65668d2bda657eb73351aa00677b2e9d8acde87c..e6bd7a6afa3258c5f57f0318f86bf549a34b26e2 100644
(file)
--- a/
libs/libffi/Makefile
+++ b/
libs/libffi/Makefile
@@
-40,6
+40,15
@@
A layer must exist above libffi that handles type conversions for values passed
between the two languages.
endef
+CONFIGURE_PATH = build
+CONFIGURE_CMD = ../configure
+MAKE_PATH = build
+
+define Build/Configure
+ mkdir -p $(PKG_BUILD_DIR)/build
+ $(Build/Configure/Default)
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) \