projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cef9287
)
[XTENSA] Add freestanding option to CFLAGS
author
Chris Zankel
<chris@zankel.net>
Sat, 4 Aug 2007 16:23:54 +0000
(09:23 -0700)
committer
Chris Zankel
<chris@zankel.net>
Mon, 27 Aug 2007 20:53:07 +0000
(13:53 -0700)
We also need to set the freestanding option for GCC in the CFLAGS.
Signed-off-by: Chris Zankel <chris@zankel.net>
arch/xtensa/Makefile
patch
|
blob
|
history
diff --git
a/arch/xtensa/Makefile
b/arch/xtensa/Makefile
index 95f836db38fa3129cd10f2574c2c8cdf1000df79..acf05be2492911ae50b270d788f0a10c69087742 100644
(file)
--- a/
arch/xtensa/Makefile
+++ b/
arch/xtensa/Makefile
@@
-27,7
+27,12
@@
platform-$(CONFIG_XTENSA_PLATFORM_ISS) := iss
PLATFORM = $(platform-y)
export PLATFORM
-CFLAGS += -pipe -mlongcalls
+# temporarily until string.h is fixed
+cflags-y += -ffreestanding
+
+cflags-y += -pipe -mlongcalls
+
+CFLAGS += $(cflags-y)
KBUILD_DEFCONFIG := iss_defconfig