ftplib: pass TARGET_CFLAGS to package build
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:52 +0000 (00:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:52 +0000 (00:56 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39806

libs/ftplib/Makefile

index f7199ad72ab47485dce90eed2becb1e6ed16a61b..1c6b51630cdf87f3b10232a85dea43f07b474792 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ftplib
 PKG_VERSION:=3.1-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nbpfaus.net/~pfau/ftplib/
@@ -32,6 +32,9 @@ applications to create and access remote files through function calls instead
 of needing to fork and exec an interactive ftp client program.
 endef
 
+MAKE_FLAGS += \
+       DEFINES="$(TARGET_CFLAGS)"
+
 define Build/Compile
        $(call Build/Compile/Default,all)
 endef