projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
efe3225
)
fix ipv4 nat on 3.7 by adding missing iptables modules
author
John Crispin
<john@openwrt.org>
Sat, 22 Dec 2012 10:17:29 +0000
(10:17 +0000)
committer
John Crispin
<john@openwrt.org>
Sat, 22 Dec 2012 10:17:29 +0000
(10:17 +0000)
SVN-Revision: 34841
include/netfilter.mk
patch
|
blob
|
history
diff --git
a/include/netfilter.mk
b/include/netfilter.mk
index 20bfffece01bb3b4ceb597b1e06ca55f46d69d3d..12c5f9fff1e20ac621961d04d192244c510ee825 100644
(file)
--- a/
include/netfilter.mk
+++ b/
include/netfilter.mk
@@
-159,7
+159,7
@@
$(eval $(call nf_add,IPT_IPV6,CONFIG_IP6_NF_TARGET_REJECT, $(P_V6)ip6t_REJECT))
# nat
# kernel only
-$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat $(P_V4)iptable_nat, ge 3.7.0),))
+$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_XT)nf_nat $(P_V4)
nf_nat_ipv4 $(P_XT)xt_nat $(P_V4)
iptable_nat, ge 3.7.0),))
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_NAT,CONFIG_NF_NAT, $(P_V4)nf_nat $(P_V4)iptable_nat, lt 3.7.0),))
# userland only