[packages] babeld: upstream release babeld-1.3.2
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Mon, 2 Jul 2012 12:54:13 +0000 (12:54 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Mon, 2 Jul 2012 12:54:13 +0000 (12:54 +0000)
30 June 2012: babeld-1.3.2

  * INCOMPATIBLE CHANGE: removed parasitic mode (-P).
  * Fixes to IPv4 support on BSD.
  * More reduction to the rate of sending requests.

SVN-Revision: 32577

net/babel/Makefile
net/babel/files/babeld.config
net/babel/files/babeld.init

index 4a8815207b1b9f41d05c9401f66bc9b28b27a757..dc7dac8aa4711dcc673a9bd2525596068fd73f15 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.3.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.3.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=bc1cb1924c61b4dad6410e342827e8c5
+PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
+PKG_MD5SUM:=56ca5107112aec09279995b7985c5ac3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,8 +22,8 @@ define Package/babeld
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=A loop-free distance-vector routing protocol
-  URL:=http://www.pps.jussieu.fr/~jch/software/babel/
-  MAINTAINER:=Gabriel Kerneis <kerneis@pps.jussieu.fr>
+  URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
+  MAINTAINER:=Gabriel Kerneis <kerneis@pps.univ-paris-diderot.fr>
   DEPENDS:=+kmod-ipv6 +librt
 endef
 
index ed63a3b5a9b269cbf50ba59f35a430826a2fc717..688da5a4f9d1c0c953201a899851be8ae91e8d0b 100644 (file)
@@ -14,7 +14,6 @@ config general
        # option 'carrier_sense' 'false'
        # option 'assume_wireless' 'false'
        # option 'no_split_horizon' 'false'
-       # option 'parasitic' 'false'
        # option 'debug' '0'
        # Listen for connections from a front-end, e.g. on port 33123.
        ## option 'local_server' '33123'
index 3550a8c4a357b08e622df54f77c90d8f010cfa1c..67a35448104e913db04563c3da4c752f9f18d6e3 100755 (executable)
@@ -97,7 +97,6 @@ babel_config() {
        append_bool "$cfg" 'carrier_sense' '-l'
        append_bool "$cfg" 'assume_wireless' '-w'
        append_bool "$cfg" 'no_split_horizon' '-s'
-       append_bool "$cfg" 'parasitic' '-P'
        append_bool "$cfg" 'keep_unfeasible' '-u'
 
        append_parm "$cfg" 'multicast_address' '-m'