backports: conditionally access net/ieee802154/ with make
authorJohannes Berg <johannes.berg@intel.com>
Mon, 10 Feb 2014 12:26:26 +0000 (13:26 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 10 Feb 2014 16:41:25 +0000 (17:41 +0100)
This essentially reverts commit cb6f08d3c38c as that caused
issues with copy-list - the scripting when generating the
backport can't prove that net/ieee802154/ isn't needed and
will try to go into it even if it wasn't copied.

Instead, make net/ieee802154/ be entered whenever it might
be needed - which is for CPTCFG_IEEE802154 and CPTCFG_BT.
This is harmless if the directory ends up listed twice but
will cause this problem to disappear.

Signed-off-by: Johannes Berg <johannes.berg@intel.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
backport/Makefile.kernel

index 0f5ed6c9b53eafaa29a012406c0076867e36e6d3..ada6decf58ee5a28299c082e0df865efdce4fd46 100644 (file)
@@ -34,7 +34,8 @@ obj-$(CPTCFG_NFC) += drivers/nfc/
 obj-$(CPTCFG_REGULATOR) += drivers/regulator/
 obj-$(CPTCFG_MEDIA_SUPPORT) += drivers/media/
 
-obj-y += net/ieee802154/
+obj-$(CPTCFG_IEEE802154) += net/ieee802154/
+obj-$(CPTCFG_BT) += net/ieee802154/
 obj-$(CPTCFG_MAC802154) += net/mac802154/
 obj-$(CPTCFG_IEEE802154) += drivers/net/ieee802154/