projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c7f0f97
)
make packages depend on +librt and +libpthread by default if eglibc is in use
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 19 Sep 2012 15:30:40 +0000
(15:30 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 19 Sep 2012 15:30:40 +0000
(15:30 +0000)
SVN-Revision: 33480
include/package-defaults.mk
patch
|
blob
|
history
diff --git
a/include/package-defaults.mk
b/include/package-defaults.mk
index c3496767cf7fd53f8a837276c23e95f6b6913234..37f814da8cf71af271939ac1eb19286f02950737 100644
(file)
--- a/
include/package-defaults.mk
+++ b/
include/package-defaults.mk
@@
-5,8
+5,10
@@
# See /LICENSE for more information.
#
+PKG_DEFAULT_DEPENDS = +libc +USE_EGLIBC:librt +USE_EGLIBC:libpthread
+
ifneq ($(PKG_NAME),toolchain)
- PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),
+libc $(filter-out +libc
,$(2)))
+ PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),
$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS)
,$(2)))
else
PKG_FIXUP_DEPENDS = $(2)
endif