kconfig: add --as-needed
authorJohannes Berg <johannes@sipsolutions.net>
Thu, 4 Apr 2013 16:08:57 +0000 (18:08 +0200)
committerJohannes Berg <johannes@sipsolutions.net>
Thu, 4 Apr 2013 16:21:19 +0000 (18:21 +0200)
18:07 < *thierryE> It's seems that for my ld version, parameters order matters
18:07 < *thierryE> Yep
18:07 < *thierryE> mconf: LDFLAGS = -Wl,--no-as-needed -lncurses
18:08 < johill> so just add the -Wl,--no-as-needed ?
18:08 < *thierryE> Yes
18:08 < *thierryE> --as-needed is enabled by default for some config

Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
backport/kconfig/Makefile

index c534359cf74f879df804c51994b6403e84489204..5974e48fa2f3784f602e05b066cb8c579fd5c58c 100644 (file)
@@ -3,7 +3,7 @@ CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
 LXDIALOG := lxdialog/checklist.o lxdialog/inputbox.o lxdialog/menubox.o lxdialog/textbox.o lxdialog/util.o lxdialog/yesno.o
 
 conf: conf.o zconf.tab.o
-mconf: LDFLAGS = -lncurses
+mconf: LDFLAGS = -Wl,--no-as-needed -lncurses
 mconf: CFLAGS += -DCURSES_LOC="<ncurses.h>" -DLOCALE
 mconf: mconf.o zconf.tab.o $(LXDIALOG)