gssdp: add package
authorFlorian Fainelli <florian@openwrt.org>
Wed, 5 Dec 2012 17:31:22 +0000 (17:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 5 Dec 2012 17:31:22 +0000 (17:31 +0000)
Signed-off-by: Andy Leiserson <andy@leiserson.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34516

libs/gssdp/Makefile [new file with mode: 0644]

diff --git a/libs/gssdp/Makefile b/libs/gssdp/Makefile
new file mode 100644 (file)
index 0000000..17f1391
--- /dev/null
@@ -0,0 +1,67 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gssdp
+PKG_VERSION:=0.12.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/gssdp/0.12/
+PKG_MD5SUM:=e7ac04abe7349a89d13d0ab4ee7d2e1b
+
+PKG_BUILD_DEPENDS:=libsoup glib2 $(ICONV_DEPENDS)
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+TARGET_LDFLAGS+=\
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/libgssdp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Library for resource discovery and announcement over SSDP
+  URL:=http://www.gupnp.org/
+  DEPENDS:=+libsoup +glib2
+endef
+
+define Package/libgssdp/description
+A GObject-based API for doing SSDP (Simple Service Discovery Protocol) transparently.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/gssdp-1.0/libgssdp}
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgssdp-1.0.{so*,la,a} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/gssdp-1.0/libgssdp/*.h \
+               $(1)/usr/include/gssdp-1.0/libgssdp/
+endef
+
+define Package/libgssdp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgssdp-1.0.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libgssdp))