projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f2b7c81
)
add LD_LIBRARY to cmake.mk
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 20 May 2011 16:21:30 +0000
(16:21 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 20 May 2011 16:21:30 +0000
(16:21 +0000)
Otherwise cmake programs try to link with host ld.so
Signed-off-by: Jan Willies <jan@willies.info>
SVN-Revision: 26963
include/cmake.mk
patch
|
blob
|
history
diff --git
a/include/cmake.mk
b/include/cmake.mk
index 22255acf590c69e625543006b7036d3e690b0739..fd8ff2d12d034f51273a77391945ae70c24d7c6d 100644
(file)
--- a/
include/cmake.mk
+++ b/
include/cmake.mk
@@
-45,6
+45,7
@@
define Build/Configure/Default
-DCMAKE_FIND_ROOT_PATH_MODE_INCLUDE=$(STAGING_DIR) \
-DCMAKE_STRIP=: \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DDL_LIBRARY=$(STAGING_DIR) \
$(CMAKE_OPTIONS) \
. \
)