projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fb2c0d1
)
ixp4xx-2.6/nslu2: Added support for building 16MB images
author
Rod Whitby
<rod@whitby.id.au>
Fri, 10 Aug 2007 13:09:12 +0000
(13:09 +0000)
committer
Rod Whitby
<rod@whitby.id.au>
Fri, 10 Aug 2007 13:09:12 +0000
(13:09 +0000)
SVN-Revision: 8388
target/linux/ixp4xx-2.6/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ixp4xx-2.6/image/Makefile
b/target/linux/ixp4xx-2.6/image/Makefile
index 8d05a1b8f1294c0dd5f6e21c1e4ff21f18889c18..70ff0ebf56a692ecf7fa6dda3ef093a62a8d02a1 100644
(file)
--- a/
target/linux/ixp4xx-2.6/image/Makefile
+++ b/
target/linux/ixp4xx-2.6/image/Makefile
@@
-25,6
+25,11
@@
ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+ BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+ -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+ -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+ -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1)-16mb.bin
endef
endif