drm/i915/oa: update the generated files
authorJani Nikula <jani.nikula@intel.com>
Tue, 30 Jul 2019 11:34:32 +0000 (14:34 +0300)
committerJani Nikula <jani.nikula@intel.com>
Fri, 2 Aug 2019 12:09:52 +0000 (15:09 +0300)
Update the generated files to make the headers self-contained, switch to
the kernel preferred SPDX comment format, and update the copyright
year. Also add the Makefile stanza to run header tests on the files.

Other changes produced by gputop i915-perf-kernelgen.py were manually
stripped out, and left to the folks who actually know something about
the OA stuff.

Cc: Chris Wilson <chris@chris-wilson.co.uk>
Cc: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Jani Nikula <jani.nikula@intel.com>
Link: https://patchwork.freedesktop.org/patch/msgid/20190730113432.22146-3-jani.nikula@intel.com
29 files changed:
drivers/gpu/drm/i915/oa/Makefile
drivers/gpu/drm/i915/oa/i915_oa_bdw.c
drivers/gpu/drm/i915/oa/i915_oa_bdw.h
drivers/gpu/drm/i915/oa/i915_oa_bxt.c
drivers/gpu/drm/i915/oa/i915_oa_bxt.h
drivers/gpu/drm/i915/oa/i915_oa_cflgt2.c
drivers/gpu/drm/i915/oa/i915_oa_cflgt2.h
drivers/gpu/drm/i915/oa/i915_oa_cflgt3.c
drivers/gpu/drm/i915/oa/i915_oa_cflgt3.h
drivers/gpu/drm/i915/oa/i915_oa_chv.c
drivers/gpu/drm/i915/oa/i915_oa_chv.h
drivers/gpu/drm/i915/oa/i915_oa_cnl.c
drivers/gpu/drm/i915/oa/i915_oa_cnl.h
drivers/gpu/drm/i915/oa/i915_oa_glk.c
drivers/gpu/drm/i915/oa/i915_oa_glk.h
drivers/gpu/drm/i915/oa/i915_oa_hsw.c
drivers/gpu/drm/i915/oa/i915_oa_hsw.h
drivers/gpu/drm/i915/oa/i915_oa_icl.c
drivers/gpu/drm/i915/oa/i915_oa_icl.h
drivers/gpu/drm/i915/oa/i915_oa_kblgt2.c
drivers/gpu/drm/i915/oa/i915_oa_kblgt2.h
drivers/gpu/drm/i915/oa/i915_oa_kblgt3.c
drivers/gpu/drm/i915/oa/i915_oa_kblgt3.h
drivers/gpu/drm/i915/oa/i915_oa_sklgt2.c
drivers/gpu/drm/i915/oa/i915_oa_sklgt2.h
drivers/gpu/drm/i915/oa/i915_oa_sklgt3.c
drivers/gpu/drm/i915/oa/i915_oa_sklgt3.h
drivers/gpu/drm/i915/oa/i915_oa_sklgt4.c
drivers/gpu/drm/i915/oa/i915_oa_sklgt4.h

index 256bfde4a28776e0d8e96691fb51ff12e703821f..df028e2b0d643f59d833d0b0a7dd175e8897b78a 100644 (file)
@@ -2,3 +2,6 @@
 
 # For building individual subdir files on the command line
 subdir-ccflags-y += -I$(srctree)/$(src)/..
+
+# Extra header tests
+header-test-pattern-$(CONFIG_DRM_I915_WERROR) := *.h
index 4acdb94555b727d3a90072cc4ff80ee148410b29..440b6b9058da81cce9a5e24fd8cde2fa1a30b87d 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index b5ed68882588629b7c3fbe097e8105225aa2f20d..0cee3334f0a6353474bbc70fd09207b75ad8475d 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_BDW_H__
 #define __I915_OA_BDW_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_bdw(struct drm_i915_private *dev_priv);
 
 #endif
index a44195c399230f6ef39b0466ca1efbab7c783de6..0b268e3fe2ab9be63e12b9b29cb5adbc81418baa 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 43c3e4ab030a517bc9a2030b6d7b05abbe67b978..0bdf391323eca01d0f43f47ce64875f6e08c34be 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_BXT_H__
 #define __I915_OA_BXT_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_bxt(struct drm_i915_private *dev_priv);
 
 #endif
index 7f60d51b87611e686dc22ea6c994992be96921d2..89542d30c55c3712fa7727e0bea86730e54c5836 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 1b4b563bc585923ed0ae9607cf3611b962dec389..6b862280ab789283a24e365048b7b5aefe081dfc 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_CFLGT2_H__
 #define __I915_OA_CFLGT2_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_cflgt2(struct drm_i915_private *dev_priv);
 
 #endif
index a92c38e3a0ce96e42f96c361941a1b424616140c..51b118b037169bfc35b3b426654774488abea466 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 500565e055cdd3dbac23a6b97d930c6841d3aee7..4ca9d8f89b2f08622a105c5fc5cdab80abaee872 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_CFLGT3_H__
 #define __I915_OA_CFLGT3_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_cflgt3(struct drm_i915_private *dev_priv);
 
 #endif
index 71ec889a01145f998f1856bc3eb540442663094d..c70c5af8a7659e2faad9785e8e682d68f5d8838d 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index ad85d6a6a5730f214902dbf4efbeb1356f96ac4b..3cac7bbc9c71a764ccfd9fdf5feba287b99650e8 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_CHV_H__
 #define __I915_OA_CHV_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_chv(struct drm_i915_private *dev_priv);
 
 #endif
index 5c23d883d6c941247f7783498e1005951feef58f..6d13983600e72f87a04f680bfe237a2e107884b2 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 9faaca38b587b5bf0f17a75abd4e685d4e7f509e..db379f5fcbb94c69551db8702a5ff748e751604e 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_CNL_H__
 #define __I915_OA_CNL_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_cnl(struct drm_i915_private *dev_priv);
 
 #endif
index 4bdda66df7d22bbb6cf2ec2a963b533a61dc0c08..668c9aa15bc578e45bab8312aed15d2dbb7de303 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index cc13a1e9fd3ea659760c7fd9c28ef549197fc857..779f343efd11a918939308af67018298c06b411a 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_GLK_H__
 #define __I915_OA_GLK_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_glk(struct drm_i915_private *dev_priv);
 
 #endif
index cc6526fdd2bdc7e7b764285313b9cc13001224f3..2e10a73127a2b06e519873a85b3e7aa8237805ba 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index f0ddcc79c761f0f0568ff8735432da9b72ff28c3..ba97f732f136062e9d65d8bd32182641fd28cae6 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_HSW_H__
 #define __I915_OA_HSW_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_hsw(struct drm_i915_private *dev_priv);
 
 #endif
index baa51427a543facad55c23105436e0512c26a4f0..6dc388de4518738117c52e5792ea30c7123599ca 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index e501651d385bdd2858700c3ca7fa6773ff6fe6ed..5c64112d720e095e2a7e2f7b5b832549f490dabd 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_ICL_H__
 #define __I915_OA_ICL_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_icl(struct drm_i915_private *dev_priv);
 
 #endif
index 168e49ab0d4d7d6e9c5965caa21b356dc9bc0df5..45b76366c4f3effe554f0b7ad88cf7ffee79ab80 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index dc460e6e0fae51e16218e0f1d24ceaa93e3e442b..810532fa6b63c378d6f12d0cb350f347122d7c6a 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_KBLGT2_H__
 #define __I915_OA_KBLGT2_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_kblgt2(struct drm_i915_private *dev_priv);
 
 #endif
index 6ffa553c388ed70ad1199772569587a445954da5..35a340f48353f9f89e6357e0fa13512310c3d191 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 5926992b735a83099ede9661f31073df25b241cc..13d70456fabdf523dc08f413f5564a96357f498b 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_KBLGT3_H__
 #define __I915_OA_KBLGT3_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_kblgt3(struct drm_i915_private *dev_priv);
 
 #endif
index 7ce6ee851d4315774ea7380dbab1d19a2df2f7af..309bb49d234ca3e705cac44e6a879184609bd967 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 353db35b36c14bf76497ec2277ac478c55763134..fda70c51a6ec30bc5a3e2612b20a1e4b8f455fa3 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_SKLGT2_H__
 #define __I915_OA_SKLGT2_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_sklgt2(struct drm_i915_private *dev_priv);
 
 #endif
index 086ca2631e1cfd87d730f694289d813c4cea11dd..4096e3ba5bb56fb5694de9f1a8979d71c05fa38e 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 52f94c674b6247a6c94b6cea05328f48c9698f90..df74eba5799eefd491bf7469ca0582d9be0be5d3 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_SKLGT3_H__
 #define __I915_OA_SKLGT3_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_sklgt3(struct drm_i915_private *dev_priv);
 
 #endif
index b291a6eb8a87b983b648bac0e135a34675bad36d..b9575b04f752c94418cb1a260f8a187ab9c0618c 100644 (file)
@@ -1,7 +1,6 @@
+// SPDX-License-Identifier: MIT
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
index 8e364820cc63041d0923f709df7fa38687daf978..378ab7ab78d55af510aecb14ee4b2948f312acd5 100644 (file)
@@ -1,7 +1,6 @@
+/* SPDX-License-Identifier: MIT */
 /*
- * SPDX-License-Identifier: MIT
- *
- * Copyright © 2018 Intel Corporation
+ * Copyright © 2018-2019 Intel Corporation
  *
  * Autogenerated file by GPU Top : https://github.com/rib/gputop
  * DO NOT EDIT manually!
@@ -10,6 +9,8 @@
 #ifndef __I915_OA_SKLGT4_H__
 #define __I915_OA_SKLGT4_H__
 
+struct drm_i915_private;
+
 void i915_perf_load_test_config_sklgt4(struct drm_i915_private *dev_priv);
 
 #endif