Created desktop feed in feeds and added wm/openbox to it.
authorJohannes Findeisen <you@hanez.org>
Sat, 17 Jan 2009 18:57:53 +0000 (18:57 +0000)
committerJohannes Findeisen <you@hanez.org>
Sat, 17 Jan 2009 18:57:53 +0000 (18:57 +0000)
SVN-Revision: 14068

desktop/wm/openbox/Makefile [new file with mode: 0644]

diff --git a/desktop/wm/openbox/Makefile b/desktop/wm/openbox/Makefile
new file mode 100644 (file)
index 0000000..490f884
--- /dev/null
@@ -0,0 +1,111 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openbox
+PKG_VERSION:=3.4.7.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://icculus.org/openbox/releases
+PKG_MD5SUM:=9e7589e90519bc6ac2f4656ea6869439
+
+TARGET_LDFLAGS+= \
+        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/libiconv/lib \
+        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/libintl/lib
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/openbox
+  TITLE:=The Openbox Window Manager
+  SECTION:=xorg-wm
+  CATEGORY:=Xorg
+  SUBMENU:=window manager
+  DEPENDS:=+glib2 +libxml2 +fontconfig +libXft +libXrandr +libXt \
++libXcursor +pango +xextproto +xf86vidmodeproto +dejavu-fonts-ttf
+  URL:=http://icculus.org/openbox/
+endef
+
+define Package/openbox/description
+  Openbox is a highly configurable, next generation window manager 
+  with extensive standards support.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/openbox/install
+       $(INSTALL_DIR) $(1)/etc/xdg/openbox
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/etc/xdg/openbox/* \
+               $(1)/etc/xdg/openbox/
+
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/openbox \
+               $(1)/usr/bin/
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/openbox-session \
+               $(1)/usr/bin/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so.* \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/lib/openbox
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/openbox/* \
+               $(1)/usr/lib/openbox/
+
+       $(INSTALL_DIR) $(1)/usr/share/pixmaps
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pixmaps/* \
+               $(1)/usr/share/pixmaps/
+
+       $(INSTALL_DIR) $(1)/usr/share/themes
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/themes/* \
+               $(1)/usr/share/themes/
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/openbox/3.4/openbox
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/openbox/3.4/openbox/* \
+               $(1)/usr/include/openbox/3.4/openbox/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so.* \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.la \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/lib/openbox
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/openbox/* \
+               $(1)/usr/lib/openbox/
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+$(eval $(call BuildPackage,openbox))