projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d24fc7e
)
add kmod-sched-netem (#8839)
author
Florian Fainelli
<florian@openwrt.org>
Tue, 5 Jul 2011 12:40:53 +0000
(12:40 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Tue, 5 Jul 2011 12:40:53 +0000
(12:40 +0000)
SVN-Revision: 27458
package/kernel/modules/netsupport.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/netsupport.mk
b/package/kernel/modules/netsupport.mk
index 8202972357a19d3fb0e1f96f0b190678290d59f6..3e546a661c8644e840d85fa7b04ab82b4c9017d4 100644
(file)
--- a/
package/kernel/modules/netsupport.mk
+++ b/
package/kernel/modules/netsupport.mk
@@
-727,3
+727,18
@@
endef
$(eval $(call KernelPackage,sctp))
+define KernelPackage/netem
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Network emulation functionality
+ DEPENDS:=+kmod-sched
+ KCONFIG:=CONFIG_NET_SCH_NETEM
+ FILES:=$(LINUX_DIR)/net/sched/sch_netem.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,99,netem)
+endef
+
+define KernelPackage/netem/description
+ Kernel modules for emulating the properties of wide area networks
+endef
+
+$(eval $(call KernelPackage,netem))
+