projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6187870
)
kernel: modules: add x86 dependency for leds-mlxcpld
author
Til Kaiser
<mail@tk154.de>
Sun, 28 Apr 2024 12:25:23 +0000
(14:25 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Thu, 29 Aug 2024 18:39:48 +0000
(20:39 +0200)
This commit adds the missing x86 dependency for
the Mellanox mlxcpld LED driver.
Signed-off-by: Til Kaiser <mail@tk154.de>
Link:
https://github.com/openwrt/openwrt/pull/15362
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/leds.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/leds.mk
b/package/kernel/linux/modules/leds.mk
index 60465a8ad507f4d5e8b4564c0d4ec0ec2ca8d66d..8b24cb0ef88e94024d4edd370100b9326de89e05 100644
(file)
--- a/
package/kernel/linux/modules/leds.mk
+++ b/
package/kernel/linux/modules/leds.mk
@@
-150,8
+150,9
@@
$(eval $(call KernelPackage,leds-apu))
define KernelPackage/leds-mlxcpld
SUBMENU:=$(LEDS_MENU)
TITLE:=LED support for the Mellanox boards
- FILES:=$(LINUX_DIR)/drivers/leds/leds-mlxcpld.ko
+ DEPENDS:=@TARGET_x86
KCONFIG:=CONFIG_LEDS_MLXCPLD
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-mlxcpld.ko
AUTOLOAD:=$(call AutoProbe,leds-mlxcpld)
endef