projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d80c91b
)
kernel: disable kmod-fs-ntfs3 for Linux 5.10
author
Rafał Miłecki
<rafal@milecki.pl>
Wed, 12 Oct 2022 09:42:36 +0000
(11:42 +0200)
committer
Rafał Miłecki
<rafal@milecki.pl>
Wed, 19 Oct 2022 05:07:14 +0000
(07:07 +0200)
This new NTFS driver was added in kernel 5.15. Avoid building empty
package for kernel 5.10.
Fixes: bd0db6017b192 ("kernel: 5.15: add new module")
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/kernel/linux/modules/fs.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/fs.mk
b/package/kernel/linux/modules/fs.mk
index 3ad458286f450e359f7e2e5576ea0ae8ef29189a..c4b68611927991d9ae6777547fd4ba74c91d0bc5 100644
(file)
--- a/
package/kernel/linux/modules/fs.mk
+++ b/
package/kernel/linux/modules/fs.mk
@@
-649,6
+649,7
@@
define KernelPackage/fs-ntfs3
KCONFIG:= CONFIG_NTFS3_FS CONFIG_NTFS3_FS_POSIX_ACL=y
FILES:=$(LINUX_DIR)/fs/ntfs3/ntfs3.ko
$(call AddDepends/nls)
+ DEPENDS+=@!LINUX_5_10
AUTOLOAD:=$(call AutoLoad,80,ntfs3)
endef