compat-wireless: use PWD for file version details
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 9 Mar 2012 01:43:26 +0000 (17:43 -0800)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 9 Mar 2012 02:10:28 +0000 (18:10 -0800)
The CFLAGS were using some local files to add some definition
of some variables later used by the compat module. Lets be
careful to use only the locally defined files.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
Makefile

index e0947986be4fb1df4193ddd3a90de6f2a142cb69..fe9d3628c4cfaab8a3ad4b9f327fa4f1e402af2e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -52,10 +52,10 @@ $(error "The path to this compat-wireless directory has spaces in it." \
 endif
 
 CFLAGS += \
-        -DCOMPAT_BASE_TREE="\"$(shell cat compat_base_tree)\"" \
-        -DCOMPAT_BASE_TREE_VERSION="\"$(shell cat compat_base_tree_version)\"" \
+        -DCOMPAT_BASE_TREE="\"$(shell cat $(PWD)/compat_base_tree)\"" \
+        -DCOMPAT_BASE_TREE_VERSION="\"$(shell cat $(PWD)/compat_base_tree_version)\"" \
         -DCOMPAT_PROJECT="\"Compat-wireless\"" \
-        -DCOMPAT_VERSION="\"$(shell cat compat_version)\""
+        -DCOMPAT_VERSION="\"$(shell cat $(PWD)/compat_version)\""
 
 # These exported as they are used by the scripts
 # to check config and compat autoconf