clish: disable libbfd usage, add missing dependency
authorFelix Fietkau <nbd@openwrt.org>
Tue, 12 Jun 2012 01:57:09 +0000 (01:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 12 Jun 2012 01:57:09 +0000 (01:57 +0000)
SVN-Revision: 32260

utils/clish/Makefile

index 4e595ed39bf9978dc026ae2343e9263e0c050265..f1774e50a6f2ff1d307461ff8e45107c15bd15df 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/clish
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libstdcpp
+  DEPENDS:=+libstdcpp +libpthread
   TITLE:=Command Line Interface SHell
   URL:=http://clish.sourceforge.net/
 endef
@@ -34,6 +34,9 @@ define Package/clish/description
  and forks the appropriate system commands to perform any actions.
 endef
 
+CONFIGURE_VARS += \
+       ac_cv_header_bfd_h=no
+
 MAKE_FLAGS += \
        bin_PROGRAMS=bin/clish