uboot-stm32: add U-Boot for stm32 boards
authorThomas Richard <thomas.richard@bootlin.com>
Thu, 26 Sep 2024 14:24:26 +0000 (16:24 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Nov 2024 14:53:21 +0000 (15:53 +0100)
Add U-Boot for stm32 boards, with the first being STM32MP135F-DK.

Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link: https://github.com/openwrt/openwrt/pull/16716
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-stm32/Makefile [new file with mode: 0644]

diff --git a/package/boot/uboot-stm32/Makefile b/package/boot/uboot-stm32/Makefile
new file mode 100644 (file)
index 0000000..58754ae
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2024 Bootlin
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_VERSION:=2024.07
+PKG_RELEASE:=1
+
+PKG_HASH:=f591da9ab90ef3d6b3d173766d0ddff90c4ed7330680897486117df390d83c8f
+PKG_MAINTAINER:=Thomas Richard <thomas.richard@bootlin.com>
+
+UBOOT_USE_INTREE_DTC:=1
+
+include $(INCLUDE_DIR)/u-boot.mk
+include $(INCLUDE_DIR)/package.mk
+
+define U-Boot/Default
+  BUILD_TARGET:=stm32
+  UBOOT_IMAGE:=u-boot.bin u-boot.dtb
+endef
+
+define U-Boot/stm32mp13
+  BUILD_SUBTARGET:=stm32mp1
+  UBOOT_CONFIG:=stm32mp13
+endef
+
+define U-Boot/stm32mp135f-dk
+  $(call U-Boot/stm32mp13)
+  NAME:=STM32MP135F-DK
+  DEVICE_TREE:=stm32mp135f-dk
+endef
+
+UBOOT_TARGETS := stm32mp135f-dk
+
+UBOOT_MAKE_FLAGS += DEVICE_TREE=$(DEVICE_TREE)
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(foreach img,$(UBOOT_IMAGE), \
+               $(CP) $(PKG_BUILD_DIR)/$(img) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(img); \
+       )
+endef
+
+define Package/u-boot/install/default
+endef
+
+$(eval $(call BuildPackage/U-Boot))