projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
05989f6
)
kernel: disable drm-i915 module for x86/geode
author
Mieczyslaw Nalewaj
<namiltd@yahoo.com>
Sun, 17 Nov 2024 07:40:44 +0000
(08:40 +0100)
committer
Petr Štetiar
<ynezz@true.cz>
Thu, 28 Nov 2024 18:47:46 +0000
(18:47 +0000)
Disable drm-i915 module for target x86/geode.
Fixes: 77cfe8f ("x86: make i915 as a kmod with required firmware")
Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
Link:
https://github.com/openwrt/openwrt/pull/16977
Signed-off-by: Robert Marko <robimarko@gmail.com>
(cherry picked from commit
226f74badd61fb1586dd3531835aeaa3bf6fe467
)
Link:
https://github.com/openwrt/openwrt/pull/17097
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/linux/modules/video.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/video.mk
b/package/kernel/linux/modules/video.mk
index fc0f038863ceaf0b5c6f8f5004ed9d95729dd900..f2fa82fd039c78cdee961c42e6f093d080393523 100644
(file)
--- a/
package/kernel/linux/modules/video.mk
+++ b/
package/kernel/linux/modules/video.mk
@@
-441,7
+441,8
@@
$(eval $(call KernelPackage,drm-amdgpu))
define KernelPackage/drm-i915
SUBMENU:=$(VIDEO_MENU)
TITLE:=Intel i915 DRM support
- DEPENDS:=@TARGET_x86 @DISPLAY_SUPPORT +kmod-backlight +kmod-drm-ttm \
+ DEPENDS:=@(TARGET_x86_64||TARGET_x86_generic||TARGET_x86_legacy) \
+ @DISPLAY_SUPPORT +kmod-backlight +kmod-drm-ttm \
+kmod-drm-ttm-helper +kmod-drm-kms-helper +kmod-i2c-algo-bit +i915-firmware-dmc \
+kmod-drm-display-helper +kmod-drm-buddy +kmod-acpi-video \
+kmod-drm-exec +kmod-drm-suballoc-helper