compat-drivers: Enable ATI/AMD Radeon for kernels >= 3.2
authorOzan Çağlayan <ozancag@gmail.com>
Sun, 28 Oct 2012 17:55:45 +0000 (19:55 +0200)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Sun, 4 Nov 2012 17:25:14 +0000 (09:25 -0800)
Signed-off-by: Ozan Çağlayan <ozancag@gmail.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
config.mk

index 5941135b9d7d687a6b158aab314cc2f749785f01..3c0a8bd2d97a832733f3c34b915353994df1ce99 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -703,16 +703,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_31
 # compilation has been tested down to 3.0 but run time
 # tests have only started on 3.2.
 ifndef CONFIG_COMPAT_KERNEL_3_2
+# Basic DRM support
 export CONFIG_COMPAT_VIDEO_MODULES=y
 export CONFIG_COMPAT_DRM=m
-export CONFIG_COMPAT_DRM_I915=m
-export CONFIG_COMPAT_DRM_LOAD_EDID_FIRMWARE=y
+export CONFIG_COMPAT_DRM_TTM=m
 export CONFIG_COMPAT_DRM_KMS_HELPER=m
+export CONFIG_COMPAT_DRM_LOAD_EDID_FIRMWARE=y
+# Intel i915
+export CONFIG_COMPAT_DRM_I915=m
+# ATI/AMD Radeon
+export CONFIG_COMPAT_DRM_RADEON=m
+export CONFIG_COMPAT_DRM_RADEON_KMS=y
 endif #CONFIG_COMPAT_KERNEL_3_2
 
 # Enable nouveau on >= 3.3
 ifndef CONFIG_COMPAT_KERNEL_3_3
-export CONFIG_COMPAT_DRM_TTM=m
 export CONFIG_COMPAT_DRM_NOUVEAU=m
 export CONFIG_COMPAT_DRM_NOUVEAU_BACKLIGHT=y
 export CONFIG_COMPAT_NOUVEAU_DEBUG=5