projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fafa3f5
)
image.mk: allow image build code to run a per-filesystem prepare step
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 25 Mar 2015 14:30:53 +0000
(14:30 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 25 Mar 2015 14:30:53 +0000
(14:30 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 44979
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index e0f12e0e8763d25f0a25b470a82a11a11c2480a4..8d21f24c240d852259ed30588da42e484bb37fc8 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-268,6
+268,8
@@
define BuildImage/mkfs
.PHONY: mkfs-$(1)
mkfs-$(1): mkfs_prepare
$(Image/mkfs/$(1))
+ $(call Build/mkfs/default,$(1))
+ $(call Build/mkfs/$(1),$(1))
$(KDIR)/root.$(1): mkfs-$(1)
endef