projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
622f8ef
)
busybox: nslookup applet link with resolv if use glibc
author
Chen Minqiang
<ptpt52@gmail.com>
Thu, 20 May 2021 08:34:28 +0000
(16:34 +0800)
committer
Paul Spooren
<mail@aparcar.org>
Fri, 21 May 2021 09:31:46 +0000
(11:31 +0200)
This fixed
b36b8b6929c6d6b17edddfb4597cf6a26a991ed0
("busybox: remove nslookup_lede/openwrt.patch")
It is likely dropped by mistake, This add back the changes
Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
package/utils/busybox/Makefile
patch
|
blob
|
history
diff --git
a/package/utils/busybox/Makefile
b/package/utils/busybox/Makefile
index 1e7d9dd33313554fe5e230203cc554180294402b..32f0d2c75598147bc4d0f1512ab3166dfa8b4569 100644
(file)
--- a/
package/utils/busybox/Makefile
+++ b/
package/utils/busybox/Makefile
@@
-98,6
+98,10
@@
endif
LDLIBS += $(call BUSYBOX_IF_ENABLED,PAM,pam pam_misc pthread)
+ifeq ($(CONFIG_USE_GLIBC),y)
+ LDLIBS += $(call BUSYBOX_IF_ENABLED,NSLOOKUP,resolv)
+endif
+
ifeq ($(BUILD_VARIANT),selinux)
LDLIBS += selinux sepol
endif