Disables inclusion of host includes ( /usrc/include/ ) as we don't provide OGG_CFLAGS...
authorFlorian Fainelli <florian@openwrt.org>
Sun, 5 Mar 2006 16:09:09 +0000 (16:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 5 Mar 2006 16:09:09 +0000 (16:09 +0000)
SVN-Revision: 3309

openwrt/package/speex/Makefile
openwrt/package/speex/patches/01-disable-host-headers.patch [new file with mode: 0644]

index 57e7ed47cf22e84e652cb8b361b3ed746eed2d9e..e1d7f2d92ba0f72e4f49a3ba7729be1deb640122 100644 (file)
@@ -21,9 +21,10 @@ $(eval $(call PKG_template,LIBSPEEX,libspeex,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
+               CFLAGS="$(strip $(TARGET_CFLAGS)) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               OGG_CFLAGS="" \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
@@ -55,6 +56,7 @@ $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               OGG_CFLAGS="" \
                bin_PROGRAMS="" \
                all install
        touch $@
diff --git a/openwrt/package/speex/patches/01-disable-host-headers.patch b/openwrt/package/speex/patches/01-disable-host-headers.patch
new file mode 100644 (file)
index 0000000..05c442b
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN speex-1.1.8/libspeex/Makefile.in speex-1.1.8.new/libspeex/Makefile.in
+--- speex-1.1.8/libspeex/Makefile.in   2005-05-06 07:00:35.000000000 +0200
++++ speex-1.1.8.new/libspeex/Makefile.in       2006-03-05 16:57:02.000000000 +0100
+@@ -107,7 +107,7 @@
+ EXTRA_DIST = testenc.c testenc_wb.c testenc_uwb.c testdenoise.c testecho.c
+-INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) @OGG_CFLAGS@
++INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) 
+ lib_LTLIBRARIES = libspeex.la