projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fe7e52e
)
iptables: use -ffunction-sections, -fdata-sections and --gc-sections
author
Jo-Philipp Wich
<jow@openwrt.org>
Tue, 21 May 2013 10:15:10 +0000
(10:15 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Tue, 21 May 2013 10:15:10 +0000
(10:15 +0000)
SVN-Revision: 36680
package/network/utils/iptables/Makefile
patch
|
blob
|
history
diff --git
a/package/network/utils/iptables/Makefile
b/package/network/utils/iptables/Makefile
index fb7aef9a0124f0421beb9a11369d09f66fa9e2ef..a0ea7f7ce0c7c1ea998f9aa6e14c84145dca74cd 100644
(file)
--- a/
package/network/utils/iptables/Makefile
+++ b/
package/network/utils/iptables/Makefile
@@
-10,7
+10,7
@@
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.18
-PKG_RELEASE:=
3
+PKG_RELEASE:=
4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
@@
-342,7
+342,11
@@
TARGET_CPPFLAGS := \
TARGET_CFLAGS += \
-I$(PKG_BUILD_DIR)/include \
- -I$(LINUX_DIR)/user_headers/include
+ -I$(LINUX_DIR)/user_headers/include \
+ -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += \
+ -Wl,--gc-sections
CONFIGURE_ARGS += \
--enable-shared \