projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3d6093c
)
tools/upx: use HOSTCXX to fix build errors on mac os x
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 22 Mar 2013 12:52:21 +0000
(12:52 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 22 Mar 2013 12:52:21 +0000
(12:52 +0000)
SVN-Revision: 36110
tools/upx/Makefile
patch
|
blob
|
history
diff --git
a/tools/upx/Makefile
b/tools/upx/Makefile
index 3e76232012d0267192016cd8048233d70a3defb1..c162e557cb5ec2bff3ece1c47b822d490861f58c 100644
(file)
--- a/
tools/upx/Makefile
+++ b/
tools/upx/Makefile
@@
-21,7
+21,8
@@
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
rm -f $(HOST_BUILD_DIR)/src/.depend
$(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
- CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
+ CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)" \
+ CXX="$(HOSTCXX)"
endef
define Host/Install