qmi: add delegate option support
authorChen Minqiang <ptpt52@gmail.com>
Wed, 15 May 2024 14:48:32 +0000 (22:48 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Sep 2024 21:43:08 +0000 (23:43 +0200)
Ipv6 delegate option is not respected by proto qmi
this add support for it.

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15508
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/utils/uqmi/Makefile
package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh

index b0433da96a4dc79121183382687317609d746892..54e1b4fc7b16a20090613a4fbdb2aab0230fdb23 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uqmi
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uqmi.git
index bec46325bcac3e70d9a840d343191e7e2e1e4c52..8ec577a90b7823033749dbbee98bf068128065b2 100755 (executable)
@@ -24,6 +24,7 @@ proto_qmi_init_config() {
        proto_config_add_boolean dhcp
        proto_config_add_boolean dhcpv6
        proto_config_add_boolean sourcefilter
+       proto_config_add_boolean delegate
        proto_config_add_boolean autoconnect
        proto_config_add_int plmn
        proto_config_add_int timeout
@@ -42,7 +43,7 @@ proto_qmi_setup() {
        local profile_pdptype
 
        json_get_vars device apn v6apn auth username password pincode delay modes
-       json_get_vars pdptype profile v6profile dhcp dhcpv6 sourcefilter autoconnect plmn ip4table
+       json_get_vars pdptype profile v6profile dhcp dhcpv6 sourcefilter delegate autoconnect plmn ip4table
        json_get_vars ip6table timeout mtu $PROTO_DEFAULT_OPTIONS
 
        [ "$timeout" = "" ] && timeout="10"
@@ -442,6 +443,7 @@ proto_qmi_setup() {
                        proto_add_dynamic_defaults
                        # RFC 7278: Extend an IPv6 /64 Prefix to LAN
                        json_add_string extendprefix 1
+                       [ "$delegate" = "0" ] && json_add_boolean delegate "0"
                        [ "$sourcefilter" = "0" ] && json_add_boolean sourcefilter "0"
                        [ -n "$zone" ] && json_add_string zone "$zone"
                        json_close_object