ntpclient: prevent stalling of hotplug events when waiting for server response (...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 22 Nov 2009 15:09:56 +0000 (15:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 22 Nov 2009 15:09:56 +0000 (15:09 +0000)
SVN-Revision: 18478

net/ntpclient/Makefile
net/ntpclient/files/ntpclient.hotplug

index 5633e7a2f4d07ff1bab0249fec8d30d75daa161c..f2ceae9c4ccf7ca37793e11c07e43c7682f8d533 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntpclient
 PKG_VERSION:=2007_365
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://doolittle.icarus.com/ntpclient/
index 29f17c1775d54be1beb3ff83f5f1d6330ac020a9..7399264d153744e3ba1b4d6a59abd5af996db009 100644 (file)
@@ -16,7 +16,7 @@ check_server() {
        config_get hostname $1 hostname
        config_get port $1 port
        [ -z "$hostname" ] && return
-       $NTPC -c 1 -p ${port:-123} -h $hostname > /dev/null && { SERVER=$hostname; PORT=${port:-123}; }
+       $NTPC -c 1 -p ${port:-123} -i 2 -h $hostname > /dev/null && { SERVER=$hostname; PORT=${port:-123}; }
 }
 
 set_drift() {