projects
/
openwrt
/
staging
/
yousong.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4101020
)
kernel: fix kmod-tpm-tis packaging
author
Jo-Philipp Wich
<jo@mein.io>
Fri, 3 Mar 2017 16:29:41 +0000
(17:29 +0100)
committer
Jo-Philipp Wich
<jo@mein.io>
Fri, 3 Mar 2017 17:14:36 +0000
(18:14 +0100)
The tmp-tis module depends on tpm_tis_core.ko, so package this file as well.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index 3b2d2e9667b09283ce7239769ce320aad5616eb5..40869c6bb0d8a2daef51d42d2e728ed7980288c2 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-974,7
+974,9
@@
define KernelPackage/tpm-tis
TITLE:=TPM TIS 1.2 Interface / TPM 2.0 FIFO Interface
DEPENDS:= @TARGET_x86 +kmod-tpm
KCONFIG:= CONFIG_TCG_TIS
- FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_tis.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_tis.ko \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_tis_core.ko
AUTOLOAD:=$(call AutoLoad,20,tpm_tis,1)
endef