kernel: add kmod-hwmon-sht3x support
authorUwe Kleine-König <uwe@kleine-koenig.org>
Sat, 12 Nov 2022 15:06:52 +0000 (16:06 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Nov 2022 14:43:08 +0000 (15:43 +0100)
The driver supports the temperature and humidity sensors chips SHT3x and
STS3x by Sensirion.

Signed-off-by: Uwe Kleine-König <uwe@kleine-koenig.org>
(cherry picked from commit cec9cbef449daea6529fbda64777ff1b7ae4e499)

package/kernel/linux/modules/hwmon.mk

index b75c741ba0a2f35efec0a1dc2851846c65f5f95a..bef9f14302fec6f23367885b5ad405068c544803 100644 (file)
@@ -474,6 +474,21 @@ endef
 $(eval $(call KernelPackage,hwmon-sht21))
 
 
+define KernelPackage/hwmon-sht3x
+  TITLE:=Sensiron SHT3x and compat. monitoring support
+  KCONFIG:=CONFIG_SENSORS_SHT3x
+  FILES:=$(LINUX_DIR)/drivers/hwmon/sht3x.ko
+  AUTOLOAD:=$(call AutoProbe,sht3x)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-lib-crc8)
+endef
+
+define KernelPackage/hwmon-sht3x/description
+ Kernel module for Sensirion SHT3x temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht3x))
+
+
 define KernelPackage/hwmon-tmp102
   TITLE:=Texas Instruments TMP102 monitoring support
   KCONFIG:=CONFIG_SENSORS_TMP102