sslh: Bump to v1.14
authorGabor Juhos <juhosg@openwrt.org>
Sat, 29 Dec 2012 18:00:04 +0000 (18:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 29 Dec 2012 18:00:04 +0000 (18:00 +0000)
Disabled support for sslh 1.12's config file feature to avoid libconfig
dependency; Redundant as we use UCI-based config file instead.

Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
Patchwork: http://patchwork.openwrt.org/patch/3080/
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34933

net/sslh/Makefile
net/sslh/files/sslh.init
net/sslh/patches/001-no_sslh_select.patch

index fd07014ec1cce3434aed4223b7b6359e91e778d4..2cde2fcce6c78106fa291ae1e689509651d0b997 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sslh
-PKG_VERSION:=1.10
-PKG_RELEASE:=2
+PKG_VERSION:=1.14
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rutschle.net/tech/
-PKG_MD5SUM:=bc34e9a4770d634633e70589c72708cc
+PKG_MD5SUM:=36e64bd6c7d0a299d5acd1109988099b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -34,6 +34,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
+               USELIBCONFIG= \
                USELIBWRAP= \
                all
 endef
index 0265656482da13cec1df3f94892b75c576e37f84..cc146864de809e6f0772b20c118977769c8ede9d 100644 (file)
@@ -42,6 +42,11 @@ start_instance() {
        config_get_bool verbosed "${section}" verbose 0
        [ "${verbosed}" -ne 0 ] && append args "-v"
 
+       # Defaults were removed for --user and --pidfile options
+       # in sslh 1.11; Define them here instead.
+       append args "--user nobody"
+       append args "--pidfile /var/run/sslh.pid"
+
        # XXX: allow more that one instance to run simultaneously
        SERVICE_MATCH_NAME=1 SERVICE_NAME="sslh-dummy-$$" \
        service_start /usr/sbin/sslh ${args}
index a7ba881cae92b1451337510e24afec3d448b0af2..71530269e2bc319943ba01ef2612d0989e28cb68 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -32,16 +32,12 @@ all: sslh $(MAN) echosrv
+@@ -37,16 +37,12 @@ all: sslh $(MAN) echosrv
        $(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -c $<
  
  
@@ -16,9 +16,9 @@
 -      #strip sslh-select
 -
  echosrv: $(OBJS) echosrv.o
-       $(CC) $(CFLAGS) -o echosrv echosrv.o common.o $(LIBS)
+       $(CC) $(CFLAGS) -o echosrv echosrv.o probe.o common.o $(LIBS)
  
-@@ -65,7 +61,7 @@ uninstall:
+@@ -77,7 +73,7 @@ uninstall:
        update-rc.d sslh remove
  
  clean:
@@ -26,4 +26,4 @@
 +      rm -f sslh-fork echosrv $(MAN) *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info 
  
  tags:
-       ctags -T *.[ch]
+       ctags --globals -T *.[ch]