projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bf3654c
)
include default package set in .target.mk
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 10 Jan 2007 16:01:07 +0000
(16:01 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 10 Jan 2007 16:01:07 +0000
(16:01 +0000)
SVN-Revision: 6061
scripts/gen_target_mk.pl
patch
|
blob
|
history
diff --git
a/scripts/gen_target_mk.pl
b/scripts/gen_target_mk.pl
index 0e4d50a74cad2edc80c39e0c1657649abaf4cbd1..2492478f9b69979ecf00fde0764b46e37aea3cdd 100755
(executable)
--- a/
scripts/gen_target_mk.pl
+++ b/
scripts/gen_target_mk.pl
@@
-70,7
+70,7
@@
foreach $target (@target) {
$profiles_eval .= "
\$(eval \$(call Profile,$conf\_$profile->{id}))"
}
- print
<<EOF
+ print
"
ifeq (\$(CONFIG_LINUX_$conf),y)
define Target
KERNEL:=$target->{kernel}
@@
-78,9
+78,10
@@
ifeq (\$(CONFIG_LINUX_$conf),y)
LINUX_VERSION:=$target->{version}
LINUX_RELEASE:=$target->{release}
LINUX_KARCH:=$target->{karch}
+ DEFAULT_PACKAGES:=".join(" ", @{$target->{packages}})."
endef$profiles_def
endif$profiles_eval
-EOF
+"
}
print "\$(eval \$(call Target))\n";