projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e01a14c
)
kernel: add a missing module for ahci on 2.6.35+
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 16 Feb 2011 15:12:54 +0000
(15:12 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 16 Feb 2011 15:12:54 +0000
(15:12 +0000)
SVN-Revision: 25553
package/kernel/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/block.mk
b/package/kernel/modules/block.mk
index a7fbe5291acac425633698869ac15f256d73ca16..21af7e5247eeeed94b9e69b56c8db970eef33deb 100644
(file)
--- a/
package/kernel/modules/block.mk
+++ b/
package/kernel/modules/block.mk
@@
-44,7
+44,12
@@
define KernelPackage/ata-ahci
TITLE:=AHCI Serial ATA support
KCONFIG:=CONFIG_SATA_AHCI
FILES:=$(LINUX_DIR)/drivers/ata/ahci.ko
- AUTOLOAD:=$(call AutoLoad,41,ahci,1)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
+ FILES += $(LINUX_DIR)/drivers/ata/libahci.ko
+ AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
+ else
+ AUTOLOAD:=$(call AutoLoad,41,ahci,1)
+ endif
$(call AddDepends/ata)
endef